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This document provides numerous 
resources to accounting professionals. 
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Chapter 8

Advanced
Features
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At this chapter’s end 
students will understand:
•  The purpose of a file template

•  How to attach ancillary documents to a T1

•  How to pay CRA using T1 PAD
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https://profile.intuit.ca/support/training/


 

 1 

Copyright                                                                          

Copyright 2020 Intuit, Inc. 

All rights reserved.                                                              

Intuit, Inc. 

5100 Spectrum Way,  

Mississauga, ON L4W 5S2 

Trademarks 

©2020 Intuit Inc. All rights reserved. Intuit, the Intuit logo, Intuit ProFile, ProAdvisor, and QuickBooks, among others, are trademarks or 

registered trademarks of Intuit, Inc. in Canada and other countries. Other parties’ marks are the property of their respective owners. 

 

Notice to Readers 

The publications distributed by Intuit Inc. are intended to assist educators by providing current and accurate information. However, no 

assurance is given that the information is comprehensive in its coverage or that it is suitable in dealing with a particular situation. 

Accordingly, the information provided should not be relied upon as a substitute for independent research. Intuit Inc. does not render any 

accounting, legal, or other professional advice nor does it have any responsibility for updating or revising any information presented herein. 

Intuit Inc. cannot warrant that the material contained herein will continue to be accurate or that it is completely free of errors when 

published. Readers should verify information before relying on them.  

 

The material in this publication is provided for informational purposes only. Laws, regulations, policy and procedures regarding this 

subject are continuously changing and the information and examples are intended as general guidelines only. This publication is sold with 

the understanding that neither the publisher nor the author are engaged in rendering professional advice and it is recommended that such 

advice be obtained before acting on any information herein. 

 

Users of this publication are responsible for their own actions and outcomes. The publishers and author therefore expressly disclaim all 

and any liability to any person in respect of anything and any consequence. Any examples in this book are factitious and any resemblances 

to actual people or circumstances are purely coincidental. 

 

 



\Table of Contents 

Introduction .............................................................................................................................................................. 3 

Benefits of Using ProFile ......................................................................................................................................... 4 

Chapter 8: Advanced Features ............................................................................................................................... 5 

File Template.............................................................................................................................................................. 5 

HyperDocs .................................................................................................................................................................. 7 

Variance and Snapshot ............................................................................................................................................. 10 

T1 Pad ...................................................................................................................................................................... 13 

Express Notice of Assessment ................................................................................................................................. 14 

Chapter 8 Quiz ....................................................................................................................................................... 16 

 

     

 

 



 

 3 

Introduction 

Intuit ProFile Tax software is reliable and easy-to-use, and it offers sophisticated features that help tax preparers 

experience a more productive tax season. The following paragraphs summarize the key components of Intuit 

ProFile Professional Tax software 

 

ProFile T1 imports and converts data created by competing software products. Whether you carry files forward 

individually or in batches, you will find the process quick and convenient. Using ProFile`s WYSIWYG (what you 

see is what you get) forms, you can view and edit federal T1 and Québec TP1 forms in either French or English. 

You can also print all tax forms in either language at the click of a button.  

 

ProFile T2 is designed for professional preparation of corporate tax returns in all provinces and territories. ProFile 

T2 includes:  
• Federal T2 returns, including T2 RSI (for 2006-2009 and earlier) and Corporation Internet Filing  

• Provincial corporate tax returns for Alberta (including AT1 RSI), for Ontario returns with taxation 

years ending prior to January 1, 2009 (including CT23 disk filing) and for Quebec (CO-17).  

• Provincial capital tax returns for Manitoba, Saskatchewan and British Columbia  

 

ProFile T3 prepares Trust income tax returns and supporting schedules, including T3 and T5 slips that the trust 

receives. Simply enter slip information on intuitive income-reporting screens and ProFile T3 automatically 

transfers the amounts to the appropriate forms. ProFile T3 also integrates business and rental income statements.  

In addition to T3 slips, the software allows you to prepare NR4 slips for non-resident taxpayers (including the 

NR4 summary).  
 

ProFile FX (Forms Expert) gives you more than 80 of the most commonly-used CRA forms which supplement 

the form-sets in Intuit`s other tax applications. Here are a few highlights of ProFile FX:  
• Customizable options help you complete and file the forms you need.  

• Automatic form selection facilitates form printing.  

• Audit and review features help pinpoint potential errors 

• Forms flexibility lets you print facsimile forms on plain paper or directly onto pre-printed CRA forms. 

ProFile FX also prepares magnetic media files for T4, T4A, T5, T5018 and NR4 slips, as well as for the 

RL1, RL2, RL3 and RL4.  

• Import identification from an existing ProFile T1 or T2 data file minimizes potential data entry errors. 



Benefits of Using ProFile 

ProFile is powerful, efficient and secure tax software that helps you get your work done fast and efficiently. 

Here’s how you benefit by using Profile: 
• With phone, email or in-product live chat support, you have year-round access to knowledgeable 

Canadian technical experts 

• With its comprehensive set of forms and schedules, ProFile lets you handle just about every tax 

scenario in any jurisdiction, including Québec 

• With a built-in auditor that runs up to 2,800 diagnostic checks of your tax returns, ProFile has your 

back  

•  Flexible Licensing means you can install ProFile on more than one personal computer without having 

to pay additional licensing fees 

• Work with QuickBooks? So does ProFile! There’s no need for manual data entry because you can now 

export data from QuickBooks directly into ProFile 

 

Plus, with ProFile you enjoy a consistent level of advanced features that include:  

• Customizable client correspondence  

• Database queries and reporting 

• Online tools to quickly and easily stay in touch with your clients 
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Chapter 8: Advanced Features 

FILE TEMPLATE  

If you find that you are constantly checking the same boxes on ProFile’s Info page (for example, the Elections 

Canada question), or if you find that most of your clients live in the same city or province, you can set up a file 

template that automatically fills in those fields for you. This capability is called a file template and, once you’ve 

set it up, Profile uses the settings in the file template to automatically fill in the fields of any new tax return. 

 

In addition to pre-filling fields, you can also set the forms (and the sequence of forms) you want ProFile to open 

when you create a new file. You can create a separate file template for each ProFile module.  

 

Note: When you carry forward prior-year files, information from the previous year will always overwrite any file 

template data.  

 

To set up a file template: 

• Create a new tax return.  

• Enter data into any field on any form. The example below has data for City and Province, as well as 

Canadian Resident, Elections Canada, and Language fields  

• Open any forms that you want ProFile to open automatically when you create a new client file that is 

based on this file template  

 



 

• Save the file with a generic name, perhaps naming it something like 2018 T1 Template 

 

 
 

• In order for ProFile to open any new file with the settings established about, go to the Options menu 

and select Module 

• Click the Browse button beside the File Template field, search and select the T1_Template file on your 

hard drive 

 

 
 

• Click OK 

 

Going forward, ProFile will use the default settings in this template file whenever you create a new file of the 

same type.  
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• If you want to share the template with other users on a network, save the template into a shared server 

folder.  

• In Client Explorer, files will display by client name or SIN. On a template, both these fields are blank. 

When you look for your template on the Client Explorer, the template file appears as NoName.  

• Select the NoName file in the database client list. Below it, you will see the file name you assigned, 

such as T1 Template, in the file details area.  

• Open the template when you need to modify the defaults for all your new clients.  

 

HYPERDOCS 

It may happen that you’d like to attach or link an electronic document to a tax file. For example, you may want to 

attach a PDF of a CRA document such as a tax ruling or an interpretation bulletin. Or you may want to link to an 

image file itemizing details of charitable donations or medical receipts.  With ProFile’s HyperDocs, you can do 

exactly that. In other words, HyperDocs lets you attach multiple documents, in any format, to a form or field of a 

T1 return. 

 

It’s important to note that any HyperDocs document attached to a tax file will be stored for internal purposes only. 

This means that no HyperDocs attachment will ever get transmitted to CRA. 

Adding a HyperDocs document 

 

You can choose to attach a HyperDocs to a tax file, or to a specific form or line in a tax file. 

 

• To add a new HyperDocs document to the tax file itself, go to File > HyperDocs and click the Add icon 

(circled in the image below) 

• A window will open letting you select the file you wish to add 

 

 
 

• To attach a HyperDocs to a specific field on a client form, right-click on the field and select Attach 
HyperDocs 

 



 
 

• After you select the file, ProFile asks whether to embed or link your document 

 

 
 

• Embedded documents open as read-only and cannot be edited in ProFile 

• Linked documents open from the source, so you can edit them directly in ProFile, and your changes 

will be saved to the source document on your computer 

Managing attached documents via HyperDocs 

Whether you add a HyperDocs to the tax file in general or to a specific area of the tax file, you will find all 

attached documents in the HyperDocs window. To view all attached documents: 

 

•  Go to File > HyperDocs 

• All attached documents appear in the HyperDocs window along with any comments that you entered. 

The HyperDocs window also lists key information that includes: 

• The date the document was attached and/or modified 

• The process you chose to attach the file (linked or embedded) 

• And the form to which the document was attached 
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Removing a HyperDocs document 

 

• To remove a HyperDocs document, right-click on the document in the HyperDocs window and choose 

Remove 

 

 
 

Deleted forms 

If you delete a form that had HyperDocs attached to it, the HyperDocs will also be deleted. Deleting a HyperDocs 

document will only remove the link or embedded document from ProFile - it will not affect the source file stored 

on your computer. 

Opening attached documents 

From the HyperDocs window, double click on the document. If the document is linked, ProFile opens it from its 

source and saves any changes you make directly to the source file stored on your computer. If the document is 
embedded, ProFile opens a read-only version. 

 

You can keep HyperDocs documents open while you continue working in ProFile. 



Synchronizing out-of-date documents via HyperDocs 

If you alter a linked document outside of ProFile, you may need to synchronize the document so that ProFile has 

the latest version of the file.  

• Because embedded documents open as read-only, to make changes to an embedded file, you must edit 

the source file and synchronize it in ProFile 

• You can edit linked documents directly in ProFile, as they open from the source and your changes are 

saved to the source file 

 

Any out-of-date, or unsynchronized, documents are displayed in red in the HyperDocs window along with an 

exclamation point icon. 

 

• To synchronize an out-of-date file, right click the document and select Synchronize 

• Alternatively, after selecting the document, click the green Snyc icon 

 
 

• Once ProFile has synchronized the document, the exclamation point will disappear, and any red 

lettering will revert to black font 

 

VARIANCE AND SNAPSHOT 

Variance is a feature that you use to highlight significant changes on a tax return. Variance lets you experiment 

with different scenarios and quickly identify the impact of those change. Variance is only calculated for fields 

with CRA line numbers. So, not all fields (for example on worksheets) will be included in the variance 

comparison. You activate the variance feature by taking a snapshot of the tax return. 

To take a snapshot of your current return 

• From the Audit menu, select Snapshot/variance and click the New button. This will take a picture of the 

current contents of the tax return 

• Give the snapshot a name that will remind you of the purpose of the scenario 

• Select the Activate this snapshot option to have ProFile compare any changes you make in the file to 

this snapshot and click OK 
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• As you make changes in the file, you can see the variance analysis on the Variance tab of the Active 

Auditor 

 

 
 

•  And you can also view the changes in ‘fly-over’ messages when your cursor is over a yellow variance 

field  

 

 
 

Shelf-life of a snapshot  

Snapshots may have a short self-life. For example, you may have created a snapshot last week using a client 

RRSP contribution of $5,000. This week you may want to evaluate the impact of reducing that contribution to 

$3,000.  

However, if you also added a new T3 slip since taking the first snapshot, variance will detect the impact of both 

the T3 and the RRSP. To best use variance, make sure you carefully manage which data fields you've changed 

since taking a snapshot.  

Deleting a snapshot  

If you change other data in the return, like adding income from a forgotten contract job, you will need to delete 

your original snapshot and create a new one, reflecting the extra income, before comparing that scenario to 

current data.  



• On the Snapshot Variance dialog (go to the Audit menu and select Snapshot/variance, select a snapshot 

that you no longer need and click the Delete button to remove that snapshot.  

 

 

Previous year variance  

ProFile includes several features to help you identify and analyze variances between two tax scenarios. If you 

carry forward information from a previous year's return, you can use these variance features to find out how much 

a field changed in comparison to the previous year.  

 

To turn on previous year variance:  

• Go to the Options menu and select Module 

• Click a module tab, for example, 2017T1  

• Click the Variance tab.  

• Select the Show previous year variance by default checkbox  

• Click OK  

 

 
 

When you carry forward a return and there is a difference between the previous and current year amounts, ProFile 

highlights the changed fields with an orange background. Move your cursor over the field to see the message 

associated with that field.  

Variance thresholds  

You can set variance thresholds to meet your own requirements. Go to the Options > Module and click the 

Variance tab.  
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Set a minimum dollar value or percentage of change that will trigger a variance calculation. If you set both a 

dollar and a percentage amount, ProFile calculates a variance only when the amount differs by more than the 

dollar value and the minimum percentage. 

 

T1 PAD  

Pre-authorized debit (PAD) is a secure, online, self-service payment option for individuals and businesses. This 

option lets you set the payment amount you authorize CRA to withdraw from a Canadian chequing account to pay 

taxes on a date, or multiple dates. 

Due to the processes that must take place between the CRA and the financial institution, the selected payment 

date must be at least five business-days from the date your PAD agreement is created or managed. 

 

A PAD agreement can only be done online. Here’s how to do it in ProFile: 

 

• Use Form Explorer to Open T1PAD 

• Type Yes to set up PAD 

• Click the Pay in full checkbox 

• If you are already set up for Direct Deposit and you want to pay from that account, enter YES. 

Otherwise enter NO and enter the bank transit info 

 

 
 

• Go to EFILE and select EFILE Pre-Authorized Debit for this Taxpayer 



• Once EFILED, ProFile will record the T1PAD confirmation number in the yellow field above, and on 

the INFO form as well 

 

 

EXPRESS NOTICE OF ASSESSMENT 

Express Notice of Assessment (NOA) is a CRA service that allows you to view the basic result of an assessment 

immediately after filing a return and to receive the full notice of assessment the next day. 

This instant assessment provides the status of your client’s return with a summary of the refund, amount owing, or 

a zero balance and deposit information, if applicable. 

The full notice of assessment provides an account summary with the result of the assessed return showing a 

refund, a zero balance, or a balance owing, tax assessment summary, explanation of changes and other 

information, and RRSP/PRPP deduction limit statement. It may also contain the Home Buyers' Plan statement and 

Lifelong Learning Plan statement. 

ENOA requirements 

To use the Express NOA service, you must: 

▪ be a registered electronic filer 

▪ be registered in Represent a Client and have a RepID, GroupID or business number 

▪ have a valid Form T1013, Authorizing or Cancelling a Representative with Level 1 (or higher) 

authorization for online access on file with the CRA 

▪ have a valid Form T183 and have completed Part C for the Express NOA function  

 

Follow these steps to activate ENOA in ProFile: 

 

▪ Navigate to the Info page and click the ENOA checkbox 
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▪ Open the T183 Form and confirm that you’d like to receive a one-time electronic notice of 

assessment. Note that ProFile warns you if you don’t have a valid T1013 on file with CRA 

 

▪ To proceed to CRA’s website and then onto your client’s notice of assessment, click EFILE > 

View Notice of Assessment (ENOA) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Chapter 8 Quiz 

Question 1: A file template is used to: 

• Ensure that all data is recorded properly 

• Create returns for various family members 

• Pre-select the fields and forms ProFile will set up on a new tax return 

• Verify the accuracy of the tax amounts 

 

 

Question 2: True or False: A different file template can be set up for each ProFile module 

 

 

 
Question 3: HyperDocs is designed to: 

• Link or embed an electronic file to a tax return 

• Add audit messages to a tax file 

• Link an amount on a tax return to the relevant information on CRA’s website 

• Create a hyperlink that can be emailed to a client 

 

 
Question 4: True or False: You can use HyperDocs to send documents such as donations receipts to CRA 

 

 

 

Question 5: True or False: HyperDocs lets you attach a document to either the tax return itself or to a line on the 

return 

 

 

 
Question 6: You synchronize a Hyperdocs file by clicking: 

• On the Synchronize command in the File menu 

• The source document in Windows Explorer 

• On the green Synchronize icon in the HyperDocs window 

• You cannot, in fact, synchronize a HyperDocs file 

 

 

 

Question 7: True or False: Once you attach a HyperDocs file to a tax return, you cannot remove it 
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Question 8: True or False: Profile uses a Snapshot to EFILE the tax return to CRA 

 

 

 
Question 9: Select one reason you would use ProFile’s Variance feature: 

• To compare the difference between two spouses’ T1 files 

• To highlight significant changes between the prior and current year’s T1 files 

• To track the last time you opened a T1 file 

• To make sure all tax preparers are using the same version of the tax file 

 

 
Question 10: CRA’s T1 Pad is used to 

A. Send an electronic payment to CRA 

B. Keep track of all amounts already paid to CRA 

C. Ensure that all client notes are saved in a notepad 

D. Modify a file that you EFILED with CRA 
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